Blog de Rafa Partida. Con la tecnología de Blogger.

Cómo instalar app que no es compatible con tu dispositivo

No entiendo muy bien porque hay aplicaciones, que Google Play considera que no son compatibles con ciertos dispositivos, cuando realmente si lo son, yo, tengo la teoría de que es por la resolución de pantalla de nuestro dispositivo o por la densidad de la misma, puntos por pulgada (ppp, en inglés dpi).

Existen algunas aplicaciones, que suelen necesitar permisos de root, que nos cambian los dpi, a nivel de configuración, de nuestro dispositivo por lo que veríamos todo más grande o más pequeño en función si ponemos más o menos dpi en esa configuración, la verdad es que no recomiendo tocar estos valores, ya que pueden darnos muchos quebraderos de cabeza.

Os cuento un caso que me paso hace poco, decidí cambiar los dpi para poder instalar algunas apps en mi tablet UNUSUAL Sirius dual elite, le puse creo recordar de 210 a 240 o de 240 a 260, y al reiniciar, cómo no encajaba en la pantalla la interfaz cada 2 segundos o menos me salia el mensaje de se ha cerrado inesperadamente X, por lo que tuve que ir poco a poco hasta la aplicación para volver a ponerlo en su valor original.

Esta aplicación es compatible con alguno de mis dispositivos por lo que puedo instalarlo en alguno de ellos y luego copiar el archivo de instalación.
Aplicación compatible con alguno de mis dispositivos.
Os voy a contar cómo instalar aplicaciones no compatibles con tu dispositivo, lo que yo suelo hacer es mirar si tengo algún dispositivo compatible en el que instalar desde Google Play la aplicación, y luego descargo la aplicación Clean Master que tiene la opción de respaldar aplicaciones y saco el archivo .apk que puedo enviarme por correo electrónico e instalarlo en el dispositivo que según Google Play no es compatible con mi dispositivo.

La última aplicación que no era compatible con mi LG G2 era la aplicación My Xbox LIVE (puedes descargar del enlace) y con este sistema he podido instalarla, si usas un dispositivo con una versión de Android bastante antigua, en mi caso un Mini 2 con Android 2.3.6 al instalarla en el otro dispositivo, os dirá que es una versión vieja y que necesita actualizarse, por lo que tuve que hacerlo en el Huawei P6 que lleva Android Kit Kat al igual que el LG G2, pero seguramente hubiera funcionado en cualquier dispositivo con Android 4.0 o superior.

Es posible que realmente no sea compatible por tamaño de pantalla, por la versión de Android u otra causa, en ese caso habría que valorar el porque no es compatible.

Aquí os dejo el vídeo de este tutorial:

Compartir en Google Plus

Sobre Rafa Partida

Soy un apasionado de las nuevas técnologias, Internet, los videojuegos, la cultura japonesa y de todo lo relacionado con Estados Unidos. @Rafa_Partida en Twitter.